How to configure Static Routing between two routers

In this section, we will be going to discuss how to configure Static Routing between two routers using Cisco Packet Tracer. You can also use other Simulation software like Boson, GNS, etc. This software is freely available on their respective official sites. You can download them and install them on your system.

However, It will be better if you can afford two live routers, but economically it is not feasible. Simulation software works well and accepts almost all the CLI commands. Hence, it is much better and economic for the hands-on practice of the Cisco router Commands.

Configuration of Static Routing

Static routing between two routers is configured manually by the network administrator. It is considered to be more reliable and secure routing than dynamic routing. But, static routing is more effective in smaller networks. As the network size increases, it is difficult to manage every router manually.

While configuring the static routing, we do not have to make the entry of directly connected networks, since they are locally connected with the router ports. We have to make the entry of indirectly connected networks via next-hop router interface IP or the exit interface.

The CLI  command for configuring static routing is:

Router(config)#ip route  [destination network]  [subnet mask]  [next hp interface IP address or Exit Interface Id]

For example:

Router(config)#ip route  192.168.1.0     255.255.255.0      10.0.0.2

Here, we are taking two routers for static routing configuration.

Let us look at the network scenario.

static-routingHow to Set up Connectivity

  •  Take two Cisco Routers Model 2911, two  Ethernet Switches, and four generic PCs.
  • Connect them using the appropriate cables.
  • Use RJ 45 copper straight cable for connecting router LAN interface ( Gigabit Ethernet Port) with Switch Fast Ethernet port and switch to PC as shown in the diagram.
  • Use Serial Cable to connect the serial interface of the two routers for point to point connection.
  • The serial interface is not integrated with the router, hence it has to be fitted externally. Insert the serial card  ( here we are taking HWIT-2T )to the appropriate serial card slot. Please be sure that the router is off while inserting the card to the slot.
  • While configuring serial interface between two routers, please keep in mind that one end will be the DCE  (Data Communication Equipment)and the other end will be DTE (Data Terminal Equipment).
  • We have to assign a clock rate or the bandwidth to the DCE end. The clock rate is written in bit per sec. Suppose, we have to assign channel bandwidth of 1Mbps, the clock rate is set as 1000000.

Distribution of IP addresses  across the respective Interfaces

Follow the table below and configure the following IP addresses to the respective ports of the two routers and the PCs.

Srl No Devices IP address | Subnet Mask  |  Default gateway Interfaces
1 Router 1 192.168.1.1     |  255.255.255.0 Gigabit Ethernet 0/0
2 Router 1 10.0.0.1              |   255.0.0.0 Serial 0/0/0
3 Router 2 192.168.2.1     |   255.255.255.0 Gigabit Ethernet 0/0
4 Router 2 10.0.0.2              |   255.0.0.0 Serial 0/0/0
5 PC 0  192.168.1.5     |   255.255.255.0    | 192.168.1.1 Ethernet
6 PC 1 192.168.1.10  |   255.255.255.0    | 192.168.1.1 Ethernet
7 PC 2 192.168.2.5     |   255.255.255.0    | 192.168.2.1 Ethernet
8 PC 2 192.168.2.10  |   255.255.255.0    | 192.168.2.1 Ethernet

 Router 1 Configuration

When the router enters into the initial set up mode after the booting process. Type NO and hit the Enter key to go to the User Exec Mode.

STEP 1.1: Configure IP Address for Gigabit Ethernet 0/0 interface

— System Configuration Dialog —

Would you like to enter the initial configuration dialog? [yes/no]: no

Press RETURN to get started!

Router1>enable

Router1#config t 

Router1(config)#interface  Gigabit Ethernet 0/0

Router1(config-if)#ip  address  192.168.1.1  255.255.255.0

Router1(config-if)#no  shutdown

Router1(config-if)#exit

Router1(config)#

STEP 1.2: Configure the IP Address for the Serial  0/0/0 interface.

Router1(config)#interface Serial 0/0/0

Router1(config-if)#ip address 10.0.0.1 255.0.0.0

Router1(config-if)#clock rate 1000000

Router1(config-if)#no shutdown

Router1(config-if)#exit

STEP 1.3: Configure Static Routing for Router 1 and save the configuration.

Router1(config)#ip route 192.168.2.0   255.255.255.0   10.0.0.2

Router1(config)#exit

Router#write 

Building configuration…

[OK]

 Router 2  Configuration

Now, configure the router 2 similarly as router 1, but with different IP addresses.

STEP 2.1: Configure IP Address for Gigabit Ethernet 0/0 interface

— System Configuration Dialog —

Would you like to enter the initial configuration dialog? [yes/no]: no

Press RETURN to get started!

Router2>enable

Router2#config t

Router2(config)#interface  Gigabit Ethernet 0/0

Router2(config-if)#ip  address  192.168.2.1  255.255.255.0

Router2(config-if)#no  shutdown

Router2(config-if)#exit

Router2(config)#

STEP 2.2: Configure the IP Address for the Serial  0/0/0 interface.

Router2(config)#interface Serial 0/0/0

Router2(config-if)#ip address 10.0.0.2 255.0.0.0

Router2(config-if)#no shutdown

Router2(config-if)#exit

STEP 2.3: Configure Static Routing for Router 1 and save the configuration.

Router2(config)#ip route 192.168.1.0 255.255.255.0 10.0.0.1

Router2(config)#exit

Router2#write

Building configuration…

[OK]

Check the configuration by executing the PING command from the PC of one network to another network. If the ping is successful, that means static routing is configured between two routers is configured successfully.


← Prev Next →
What is IP Routing and it’s Types What is Dynamic Routing and it’s Types

, , , , , , , ,

Leave a Reply